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Chapter 1: Operating System

and Uti l i t ies

This release notes chapter describes V2.2.9 of the OS-9 for SH-4 operating 
system.
7



Operating System and Utilities1

Known Issues

attr Does Not Change Attributes

The utility attr does not change the attributes of a specified file in a PCF file 
system device. This issue is a limitation imposed by the PC file system.

Boot Code

The kermit booter (llkermit) is known not to work.

Building Boots with the Wizard

The Wizard version 1.28 has an additional menu called “Customize”. The new 
“Choose Utility Subset” dialog allows you to select the utilities you would like 
and reduces the bootfile size. For backwards compatibility with the Wizard, 
version 1.27, you may use the full set of disk utilities and/or embedded ROM 
utilities. If you decide to use customized utilities, there will be no effect if you 
check the “ROM Utility Set” check box or “Disk Utilities” check box in the 
“Master Builder” dialog. Only selected utilities will be included. If you want to 
include the utilities by setting the “Disk Utilities” and/or “ROM Utility Set” flags, 
do not select any utility provided by the “Customize” menu.

Failure of Alarm Sequences

An error message was not generated when testing invalid sequences of 
alarms in user state and in system state:

A_ATIME(non-pending), A_DELET,
A_ATIME(non-pending), A_RESET.

In these two cases, an error message should have been generated because 
non-pending alarms (alarms that have already gone off) are removed from the 
system. Trying to delete a non-existent alarm should generate an error 
message, but the delete and reset commands did not return an error.
8 Enhanced OS-9 for SH-4 Release Notes



Operating System and Utilities 1

PCMCIA Interrupts

The SanDisk 4 MB and 20 MB PCMCIA ATA IDE cards do not work correctly 
with PCMCiA IDE interrupts. To make sure that all cards work with OS-9, the 
default mode for accessing PCMCIA IDE cards is polled mode. 
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See the Enhanced OS-9 for Super H 7750SE01 Board Guide 
for information on enabling PCMCIA IDE interrupts.

Register Wait States

Due to the way the SH7750 operates it’s execution pipelines, CPU read-write 
access to some of the internal registers (such as SR - Status Register) and 
memory-mapped registers have to be followed by wait cycles. For example, 
performing a read instruction immediately after a write instruction on the SR 
does not return a correct result as one would expect. Therefore, it is 
necessary to place "dummy" wait instructions between the write and read 
instructions. 

Since the number of wait cycles differs for various registers and that it may be 
changed in future variations of SH-4 processors, it was decided not to include 
the common register access routine in cpu.l and let the developers to do it 
as needed for their drivers. One of the software modules which had to take 
these wait states into account was romcore.

To provide future OEM users with flexibility to eliminate dummy wait states, the 
makefile for romcore (located at 
\mwos\OS9000\SH4\PORTS\SH7750SE\ROM\ROMCORE\makefile) has 
MOD_LVECTORS defined which controls the inclusion of wait states between 
writing and reading of the SR (status register). Disabling this flag takes these 
wait states off." 
Enhanced OS-9 for SH-4 Release Notes 9



Operating System and Utilities1

Selecting Java Support in Wizard

It is possible to select the checkbox labeled JAVA Support in the 
Configuration Wizard’s Master Builder window even when the PersonalJava 
for OS-9 package is not installed. This checkbox should not be selected if you 
do not have PersonalJava for OS-9 installed. Selecting this checkbox for a 
build when PersonalJava for OS-9 is not installed will result in an error.
10 Enhanced OS-9 for SH-4 Release Notes



Operating System and Utilities 1

Additional Features

SCSI Support

Since the Solution Engine board had no onboard SCSI devices, there is no 
official SCSI support for this release. However SCSI drivers have been 
included in case OEM’s want to add SCSI to their SH-4 hardware. Please note 
that these SCSI drivers have not been tested for SH-4 and are shipped “as is.”

SH7750 Cache Mask

There is an init module definitions for the m_cpucompat field that will control 
cache behavior.

CACHE_WT_MASK: By setting this bit in the m_cpucompat field, the cache 
module will set up write-through mode for memory areas P0, U0, and P3.

By default, this bit is not set.
Enhanced OS-9 for SH-4 Release Notes 11



Operating System and Utilities1

Supplemental Documentation

iopt Command Line Options

iopt has command line options to control processor-specific optimizations:

Each of these optimizations are enabled for SuperH processors. If the need 
should arise to disable them, use the options listed above.

-e suppress all processor specific optimizations

-ec suppress creation of CSEs containing complex constants

-ef suppress creation of CSEs containing function addresses

-eg suppress creation of CSEs containing global variable 
addresses
12 Enhanced OS-9 for SH-4 Release Notes



Chapter 2: Hawk IDE and HawkEye

This release notes chapter describes release V1.2 of Hawk and release V1.0 
of Hawkeye
13



Hawk IDE and HawkEye2

Hawk Known Issues

Target Connection

In order to connect to the target in user state, you need to run spfndpd in the 
background.

Installation Location

Hawk needs to be installed on a computer that does not have a previous 
version of the Ultra C compiler resident on it.

Attaching to a Module

Attaching to a module during a system state debugging session when the 
debugger connection is not active (host is currently running) invalidate the 
debugging session. Hawk must be restarted and the target reset before a 
system state connection can be re-established.

Moving Projects

Moving projects into different locations is not available. If you must move a 
project, manually modify preferences of the project.

Aborting a system state connection

Aborting a system state connection is not currently supported in Hawk.
14 Enhanced OS-9 for SH-4 Release Notes



Hawk IDE and HawkEye 2

Setting Break Points

You may be unable to set break points at some locations, such as the first line 
of code. To work around this problem, set the break point on main and trace to 
the first line or you can create a dummy first statement.

Response Delays

Hawk may take a few seconds to respond after hitting a break point or the 
step/next functionality in the debugger when debugging in system state.

Absolute Paths

Hawk projects require absolute paths. For example if a project is developed on 
drive C and moved to drive D, you should modify the paths within the project 
for all source and output folders of the Projects Properties dialog.

Forked Process

Preloading programs
Hawk requires programs to be preloaded in the target’s memory in order to 
perform debugging. This implies that if a main process forks several child 
processes, you must preload all corresponding modules, including the main 
module in case it forks itself. 

Process forking itself
Hawk does not allow you to debug a process which forks itself. If you 
encounter this situation, make a clone of the corresponding module with a 
different name and modify the main process to call this clone.
Enhanced OS-9 for SH-4 Release Notes 15



Hawk IDE and HawkEye2

System State and spf Daemons

You cannot run system state if spf daemons are running.

Attaching Module in System State

If you attempt to attach a module in system state when the connection is not 
active (connection is established and go has been done), Hawk comes back 
with an error cannot attach. After this, typing break on the target does not 
restore the system state connection. 

SPF In System State Debugging

SPF cannot be used over Ethernet during system state debugging. If you start 
SPF on the target when using Hawk to debug in system state, Hawk will fail to 
connect to the target. You can use SPF and system state debugger over SLIP 
instead.

Output Window

The Hawk output window does not have a buffer large enough to hold long 
output. This problem will be addressed in a future release.

Function Keys

Active sub window
If any sub window (window other than Hawk main and source windows) is 
active, the function keys for step/next for assembly/source instructions do not 
work.
16 Enhanced OS-9 for SH-4 Release Notes



Hawk IDE and HawkEye 2

Stepping
In the debug window, the function keys to run or start stepping through a 
program don’t work until you place your cursor inside the window containing 
code.

Next
If you maximize the code box, you will see an icon to the left of the File menu 
at the top of the screen. I you click that icon, one of the choices is “Next 
Ctrl+F6” However, Ctrl+F6 does not work properly. 

Compiler

The SH-4 back end sometimes emits gratuitous moves when moving floating 
point values into the floating point registers specified by the SH-4 ABI.

Windows

Watch Windows
Global variables of a program do not update in the watch window, but the 
actual change is performed in the program.

Lingering Windows
If you experience lingering windows, such as the properties and compilation 
windows, do not run Hawk with Perfect Screens. The two software packages 
do not work together.

Output Buffer Scroll Bars
Vertical and horizontal scrollbars in the output buffer return to the original 
position of the cursor when released. Instead, use the scroll arrows, which 
work properly.
Enhanced OS-9 for SH-4 Release Notes 17



Hawk IDE and HawkEye2

ToolBar Buttons

Adding/Removing toolbar buttons
It is possible to remove buttons from the debug toolbar, but you will be unable 
to add them back to the toolbar. 

Empty debug toolbar
If the debug toolbar shows up empty with no button icons in it, comment a line 
containing “Debug” string in $(MWOS)/DOS/BIN/mwhawk.ini file and 
restart the debugging session.

Buttons not functioning
The toolbar buttons will not function if the Hawk window background is 
selected.

Next error button
The next error button on the toolbar (looks like three triangles with the letters 
ERR) clears all errors in the build window at the bottom of the screen and 
doesn’t advance to the next error.

Question mark icons
In the Toolbar Customization dialog box, the two question mark icons both 
perform the same operation, “Help for keyword under cursor.”

Spell Check

If you select Tools->Spell Check you may receive a warning: Function 
“DlgSpellCheck” not found .
18 Enhanced OS-9 for SH-4 Release Notes



Hawk IDE and HawkEye 2

Cleanup Option/Incremental Link

There is no cleanup option or incremental link option in the current version of 
Hawk.

Profiler

Opening a .prf file
Opening a .prf file, followed by starting a profile session in the file’s context 
may cause erratic behavior (like a dead profiler session, module list not 
displayed, etc.). Open is simply to view a previously saved profile. For a new 
profile, do a New, and then Profile. If you chose to do an Open, it is 
recommended that you invoke a new profiler session for future profiling.

Alternate connections
Alternate connections to the target do not work if the new connection is being 
established when spfnppdc for the existing connection has not exited. This 
issue is caused by timing related issues on the target.

Update
Double/multiple entries are added on clicking the Update button several times 
before the earlier ones are complete.

Target IP address
In the absence of DNS, create a host file called hosts in the Windows 
directory. Sample host file:

172.16.2.217 <host_name 2>
172.16.2.45 <host_name>
Enhanced OS-9 for SH-4 Release Notes 19



Hawk IDE and HawkEye2

Stop to view
If you select Stop to view in the Display Parameter window, you can still view 
the update information in the main window by pulling the horizontal scrollbar 
to the far right and then bringing it back to the far left.

File -> Save As 
The display has an Open button instead of a Save button. This button does 
perform a Save operation.

Multiple Sessions
Multiple profile sessions to a target is not supported.

Overwrite Warning
Save does not display an overwrite warning if the file already exists and 
assumes the working draft can be overwritten.

Open without file extension
The file name with extensions has to be specified to open a .prf file.
20 Enhanced OS-9 for SH-4 Release Notes



Hawk IDE and HawkEye 2

HawkEye Known Issues

• Hawkeye uses timer 1 on the SH7750 board. 

• When starting HawkEye, select File->Preferences->Target and choose 
the SuperH4 processor type.  HawkEye’s current default processor is 
PowerPC.

• If the router daemon locks up, reset the target to capture any future 
profiles.

• Currently, logging to a user log is not supported on the SH-4. User events 
are logged directly into the system log.

• The PC values corresponding to some of the kernel’s internal system calls 
are not set to enhance performance.

• The process ID (PID) is set to the program that calls the kernel.  Because 
of this, the system call event will show up in the log file as part of the 
calling process. Furthermore, the PC value is not properly set in the 
details window for the system call events.

• The stack indicated is the system stack. Some of the system calls include 
the following:

F_UACCT

F_MOVE

F_CMPNAM

F_PRSNAM

F_INITDATA

F_SLINK

F_TLINK

I_IOEXIT

I_IOFORK

I_IODEL

F_SALARM

I_OPEN

I_GS_DEVTYPE

I_GS_DSIZE
Enhanced OS-9 for SH-4 Release Notes 21



Hawk IDE and HawkEye2

I_READ

I_CLOSE

I_GS_EOF

I_GS_FD

• If the filters are applied in the Filter Criteria dialog box, the system call 
events will not show up in the HawkEye application window.  However, the 
details will show up in the Details dialog box.  
22 Enhanced OS-9 for SH-4 Release Notes



Chapter 4: LAN Communications

Pak

This release notes chapter describes V3.3 of the LAN Communications Pak.
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LAN Communications Pak4

Enhancements/Changes

IP Address Configuration

The IP address is now configurable from the General Purpose switches if not 
specified through the wizard. SW5 contains the Most Significant byte of the 
address and SW9 contains the Least Significant Byte. (For the GP switches 
ON is read as 0 and OFF is read as a 1.)

SPF IP Address

The IP address for the SPF system is read (if not specified in the inetdb 
modules/wizard) from the low level system (if present).

Ethernet IP Address

The Least Significant byte for the Ethernet address is now read from General 
Purpose Switch SW9.
24 Enhanced OS-9 for SH-4 Release Notes



LAN Communications Pak 4

Open Issues

Remote mkdir

Remote mkdir to a RAM disk fails from within an ftp client session

IP Address change

If the IP address is changed after the IP stack is initiated (using ifconfig for 
example), User Datagram Protocol transmits continue to use the original 
address.
Enhanced OS-9 for SH-4 Release Notes 25
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Product Discrepancy Report

To: Microware Customer Support

FAX: 515-224-1352

From:_____________________________________________

Company: _________________________________________

Phone:____________________________________________

Fax:__________________ Email:_______________________

Product Name: 

Description of Problem:
_________________________________________________

_________________________________________________

_________________________________________________

_________________________________________________

_________________________________________________

_________________________________________________

_________________________________________________

_________________________________________________

_________________________________________________

Host Platform ______________________________________

Target Platform _____________________________________
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